Help with log in

Can someone message me with the right download info if i have the wrong one installed? I’ve been trying to log in but it keeps saying unable to validate game version… I play on elysium all the time. do they have a different version? 1.12.1 is what i have installed currently. please help

Yeah, I’m having the same issue. I tried Elysium and another client and it goes to “Disconnected” after a few seconds.

Not sure if it’s problems on our end or theirs.

nope all works fine, change realmlist to:
set realmlist

did you do that?

I had same issue. I had 2 copies of clients I have used on other servers. re downloaded fresh client and works.

Grab your self “free bit torrent” off play store , manually search for wow 1.12 and start download , it will probably stop 5x saying error but keep whacking “start” to get it going again. It will fail towards the end when you have 1% or something to go , do not worry simply go in that download folder and hit the “wow” icon after setting realmlist it works .

I had same issue trying to find elysium and all the other clients that dont exist anymore.

I am a boomer with 0 technical knowledge , I cant even operate mobile phones and I am ex infantry so I cant count past 20 as I run out of toes and fingers you guys have got this!!

I was about to made a new topic but i “bump” on this oen so devs can check.
I have same issue!!! I can log and play in Elysium but not everlook! Im preety dissapointed atm… And no dont want to run any installer made by anyone that requires admin access…
And too bad cuz i did promote the server to warmane players who love classic but are stuck in warmane!
Either the devs must upload some mpq’s or soemthing else is the problem… It seems that maybe everlook files are different cuz maybe ellysium is fine, I dont know all i do know is that i can’t join.
Also… the proccessing of picture uploading takes ages…

Do not install anything custom.
That sounds really fishy.

You ONLY need a clean 1.12.1 client.
Make sure to change the
Make sure to launch WoW and not the launcher from blizzard.
You NEED to verify your e-mail address

And if there are still issues, try deleting the WDB and WTF folder!

Hope this helps

Thanks for the fst replay all steps are done i try the ones with the folders.

1 Like

Update , i did deleted the suggested files. When it reached connection it returns " Disconected form server"
Thank you.

1 Like

“Disconnected from the server”
Can be because there is work currently done:

Also bear in mind you only could log-in to make your character (name reservation) and log back out. (But not atm. because of the work that is being done)
The official launch is today (11th) in about 6 hours and 18 minutes

Hope it works for you!