How to run WoW 32-bit on macOS

How to run WoW 32-bit on macOS

  • You need a to have a Windows client of WoW
  • Open this URL: Releases · Gcenx/WineskinServer · GitHub
  • Under the latest release section, expand Assets
  • Download Wineskin.Winery
  • Extract the Wineskin and place it in your Applications
  • Open Wineskin with right-click → Open (or the system doesn’t let you open it)
  • Click on the “+” sign to add an Engine
  • Select the engine WS11WineCX64Bit19.0.2
  • Click on “Download and install”
  • In the “Wrapper Version” area click Update

This is how it should look like (the version numbers can be different than yours):

Wineskin Winery on macOS Catalina

  • Click Create New Blank Wrapper
  • Choose a name for the wrapper, e.g. “WoW335”
  • Click ok, it will now take some time to load
  • If it asks to download Gecko or similar, accept and continue
  • Click View wrapper in Finder, pay attention to the location so you know where to find it again – you can also add it to your Dock
  • The folder contains your WoW wrapper, e.g. “”
  • Open it with right-click → Open (or the system doesn’t let you open it)
  • Click Install software
  • Select Copy a Folder Inside
  • Select your World of Warcraft folder within your computer
  • It will ask you for the default executable, select Wow.exe and close the window
  • You can now open your .app wrapper (e.g. “”) to run the game.
  • Have fun!



Good job man, keep it up!

Does this work on M1 Macs?

i do not have any m1 mac at my disposal, but i’ll try to do some tests. Also there is just mac version of a cline for 1.12. i have it. and one of the eoptions is to just use the windows client with instead of WoW.exe

1 Like

hope you can try it

I can unfortunately confirm that this does not work on MacOS Monterey M1 Max Mac. These don’t seem to be able to run 32-bit clients in any format. So far I haven’t found a workaround for 1.12.1 clients.

Source: I just tried on my own with the following error message.
Skærmbillede 2022-11-07 kl. 21.16.53


I have a M1 Max Mac and run the Windows 1.12.1 client through Parallels Desktop with Windows 11. With vsync enabled on 60hz display, 1080p resolution and best possible settings (including the VanillaGraphicBoost addon), it mostly stays in the 50-60fps range, with some dips to 40-45 fps. So it is playable, but could be smoother. I decided to buy a dedicated windows gaming pc for the best possible experience, with the amount of time I plan to spend here.


most likely i will be able to test it on weekend, erroe 132 is very common, i had it alot of time when i was playing on TWOW. but then i changed the wineskin engine and it now roks just fine. as soon as i can test it on m1 i’ll let you all know.


We look forward to your conclusion


I can confirm that on Ventura (13.0) mac with M1 processor the client is running ok under Parallels (win 11) … and i get same error with Wineskin
I hope someone more into tinkering can find a sollution as not all of us are interested in buying parallels :slight_smile:

One of the other options is theta you get the windows client (already unpacked and installed) and just put the from mac client and put it inside the wow directory you have. It may not launch first, but you can right click the and Show content, then macOS and start the wow, it will launch the client. but it worked on macOS El capitan and Mojave, HIgh Sierra aswel. Also i do have the 1.12.1. mac client the official one.

1 Like

Can you share with us the mac client? much appreciated ofc!!!

I got it from kronos via torrent, but i’ll upload it to mediafire tonight, at work atm

Unfortunately you can’t use the MacOS client on newer models or OS’s due to it being a 32-bit client, which Apple doesn’t support anymore. Seems like Parallels Desktop is the only solution, which is sad since it both costs money and does not run as well as any clients opened directly on the Mac without a third-party application.

When trying to open a Mac client it will appear like this and link you to the following website:

It should be a missing dependency file

This is it: we are stucked with Parallels subscription :slight_smile:

I used “playonmac”
picked the game from gamelist - windows client. (make sure its named WoW.exe)

Then installed.

Good luck.

1 Like

What version of MacOS are you running and which processor does your Mac have? It won’t let me install it on mine. And when I try manual download I just get same error as with Wine

My potato has Cantalina.

I have tested this method and it is always reporting errors.
engine WS11WineCX64Bit19.0.2 also can not be downloaded, now the lowest version is

My apple host is macbook air M1 16G 1T